Ignore:
Timestamp:
03/17/08 11:35:12 (16 years ago)
Author:
pawelk <pawelk@…>
Branches:
master, help
Children:
d593c5e
Parents:
246900a
git-author:
pawelk <pawelk@…> (03/17/08 11:35:12)
git-committer:
pawelk <pawelk@…> (03/17/08 11:35:12)
Message:

Poprawiłem skrypty, generujące dystrybucję tarball oraz rpm.
Można testować: make dist_tarball oraz make dist_rpm.

git-svn-id: svn://atos.wmid.amu.edu.pl/utt@11 e293616e-ec6a-49c2-aa92-f4a8b91c5d16

File:
1 edited

Legend:

Unmodified
Added
Removed
  • app/dist/spec/utt.spec

    r25ae32e rb2647de  
    1111%define _this_summary     Some tools for text processing 
    1212%define _this_name        utt 
    13 %define _this_version     %(cat ../common/version.def) 
    14 %define _this_release     %(cat ../common/release.def) 
     13%define _this_version     %(cat ../../common/version.def) 
     14%define _this_release     %(cat ../../common/release.def) 
    1515%define _this_copyright   Adam Mickiewicz University, Poland 
    16  
    17 # 
    18 # We need some paths 
    19 # 
    20 # Directory with utt binaries 
    21 %define _UTT_DIST_DIR   %(pwd) 
    22 #Root directory in which utt will be installed 
    23 %define _UTT_DIR                /usr/local/%_this_name 
    24 #Directory for rpm 
    25 %define _RPM_ROOT       %_UTT_DIST_DIR/../rpm_root 
    2616 
    2717# 
     
    4030URL:         http://utt.amu.edu.pl 
    4131Vendor:      Adam Mickiewicz University 
    42 BuildRoot:   %_RPM_ROOT 
     32BuildRoot:      %(pwd) 
    4333#BuildArch:      i586 
    4434# requirements for utt application 
     
    5343 
    5444%description 
    55 %(cat ../common/description.def) 
     45%(cat ../../common/description.def) 
    5646 
    5747%description -l pl 
    58 %(cat ../common/description.pl.def) 
     48%(cat ../../common/description.pl.def) 
    5949 
    6050 
     
    6858# rpm building 
    6959%install 
    70 %__mkdir_p $RPM_BUILD_ROOT%_UTT_DIR 
    71 cp -fr %_UTT_DIST_DIR/* $RPM_BUILD_ROOT%_UTT_DIR/ 
    72  
    7360 
    7461# cleaning after rpm build 
    7562%clean 
    76 rm -rf $RPM_BUILD_ROOT 
    7763 
    7864# ------------------------------------------------------------- 
     
    8066%pre 
    8167 
    82  
    8368#after installation 
    8469%post 
    8570# we need to create utt.conf file 
    86 %_UTT_DIR/create_utt_config.pl 
    87 rm -f %_UTT_DIR/create_utt_config.pl 
    88 # we need to create links in /usr/local/bin 
    89 find %_UTT_DIR/bin/ -type f -exec ln -f {} /usr/local/bin \; 
    90  
    9171 
    9272#before uninstallation 
    9373%preun 
    94 # we delete links from /usr/local/bin 
    95 for fn in `find %_UTT_DIR/bin/ -type f -exec basename {} \;`; do rm -f /usr/local/bin/$fn; done 
    96  
    9774 
    9875#after uninstallation 
    9976%postun 
    100 # we remove all extra files 
    101 rm -fr %_UTT_DIR 
    10277 
    10378# ------------------------------------------------------------- 
Note: See TracChangeset for help on using the changeset viewer.