Changeset b2647de for app/dist/spec/utt.spec
- Timestamp:
- 03/17/08 11:35:12 (17 years ago)
- Branches:
- master, help
- Children:
- d593c5e
- Parents:
- 246900a
- git-author:
- pawelk <pawelk@…> (03/17/08 11:35:12)
- git-committer:
- pawelk <pawelk@…> (03/17/08 11:35:12)
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
app/dist/spec/utt.spec
r25ae32e rb2647de 11 11 %define _this_summary Some tools for text processing 12 12 %define _this_name utt 13 %define _this_version %(cat ../ common/version.def)14 %define _this_release %(cat ../ common/release.def)13 %define _this_version %(cat ../../common/version.def) 14 %define _this_release %(cat ../../common/release.def) 15 15 %define _this_copyright Adam Mickiewicz University, Poland 16 17 #18 # We need some paths19 #20 # Directory with utt binaries21 %define _UTT_DIST_DIR %(pwd)22 #Root directory in which utt will be installed23 %define _UTT_DIR /usr/local/%_this_name24 #Directory for rpm25 %define _RPM_ROOT %_UTT_DIST_DIR/../rpm_root26 16 27 17 # … … 40 30 URL: http://utt.amu.edu.pl 41 31 Vendor: Adam Mickiewicz University 42 BuildRoot: %_RPM_ROOT32 BuildRoot: %(pwd) 43 33 #BuildArch: i586 44 34 # requirements for utt application … … 53 43 54 44 %description 55 %(cat ../ common/description.def)45 %(cat ../../common/description.def) 56 46 57 47 %description -l pl 58 %(cat ../ common/description.pl.def)48 %(cat ../../common/description.pl.def) 59 49 60 50 … … 68 58 # rpm building 69 59 %install 70 %__mkdir_p $RPM_BUILD_ROOT%_UTT_DIR71 cp -fr %_UTT_DIST_DIR/* $RPM_BUILD_ROOT%_UTT_DIR/72 73 60 74 61 # cleaning after rpm build 75 62 %clean 76 rm -rf $RPM_BUILD_ROOT77 63 78 64 # ------------------------------------------------------------- … … 80 66 %pre 81 67 82 83 68 #after installation 84 69 %post 85 70 # we need to create utt.conf file 86 %_UTT_DIR/create_utt_config.pl87 rm -f %_UTT_DIR/create_utt_config.pl88 # we need to create links in /usr/local/bin89 find %_UTT_DIR/bin/ -type f -exec ln -f {} /usr/local/bin \;90 91 71 92 72 #before uninstallation 93 73 %preun 94 # we delete links from /usr/local/bin95 for fn in `find %_UTT_DIR/bin/ -type f -exec basename {} \;`; do rm -f /usr/local/bin/$fn; done96 97 74 98 75 #after uninstallation 99 76 %postun 100 # we remove all extra files101 rm -fr %_UTT_DIR102 77 103 78 # -------------------------------------------------------------
Note: See TracChangeset
for help on using the changeset viewer.