Last change
on this file since 2f8d6d8 was
b2647de,
checked in by pawelk <pawelk@…>, 17 years ago
|
Poprawiłem skrypty, generujące dystrybucję tarball oraz rpm.
Można testować: make dist_tarball oraz make dist_rpm.
git-svn-id: svn://atos.wmid.amu.edu.pl/utt@11 e293616e-ec6a-49c2-aa92-f4a8b91c5d16
|
-
Property mode set to
100644
|
File size:
1.6 KB
|
Line | |
---|
1 | # |
---|
2 | # Default RPM header. |
---|
3 | # |
---|
4 | # START_RPM_STD_HEADER: |
---|
5 | |
---|
6 | |
---|
7 | # |
---|
8 | # RPM properties |
---|
9 | # |
---|
10 | %define _this_product UAM Text Tools |
---|
11 | %define _this_summary Some tools for text processing |
---|
12 | %define _this_name utt |
---|
13 | %define _this_version %(cat ../../common/version.def) |
---|
14 | %define _this_release %(cat ../../common/release.def) |
---|
15 | %define _this_copyright Adam Mickiewicz University, Poland |
---|
16 | |
---|
17 | # |
---|
18 | # Default RPM header. |
---|
19 | # |
---|
20 | # END_RPM_STD_HEADER: |
---|
21 | # -------------------------------------------------------------------- |
---|
22 | |
---|
23 | Summary: %_this_summary |
---|
24 | Name: %_this_name |
---|
25 | Version: %_this_version |
---|
26 | Release: %_this_release |
---|
27 | #Copyright: %_this_copyright |
---|
28 | License: GPL |
---|
29 | Group: Development/Tools |
---|
30 | URL: http://utt.amu.edu.pl |
---|
31 | Vendor: Adam Mickiewicz University |
---|
32 | BuildRoot: %(pwd) |
---|
33 | #BuildArch: i586 |
---|
34 | # requirements for utt application |
---|
35 | #AutoReq: no |
---|
36 | #AutoReqProv: no |
---|
37 | |
---|
38 | #Requires: glibc >= 2.1.3 |
---|
39 | #Requires: libgcc1 >= 3.0 |
---|
40 | #Requires: libgcc >= 3.0 |
---|
41 | #Requires: libstdc++6 >= 3.4.1 |
---|
42 | #Requires: libstdc++ >= 3.4.1 |
---|
43 | |
---|
44 | %description |
---|
45 | %(cat ../../common/description.def) |
---|
46 | |
---|
47 | %description -l pl |
---|
48 | %(cat ../../common/description.pl.def) |
---|
49 | |
---|
50 | |
---|
51 | # ------------------------------------------------------------- |
---|
52 | # preparing sources for compilation |
---|
53 | %prep |
---|
54 | |
---|
55 | # source compilation |
---|
56 | %build |
---|
57 | |
---|
58 | # rpm building |
---|
59 | %install |
---|
60 | |
---|
61 | # cleaning after rpm build |
---|
62 | %clean |
---|
63 | |
---|
64 | # ------------------------------------------------------------- |
---|
65 | #before installation |
---|
66 | %pre |
---|
67 | |
---|
68 | #after installation |
---|
69 | %post |
---|
70 | # we need to create utt.conf file |
---|
71 | |
---|
72 | #before uninstallation |
---|
73 | %preun |
---|
74 | |
---|
75 | #after uninstallation |
---|
76 | %postun |
---|
77 | |
---|
78 | # ------------------------------------------------------------- |
---|
79 | %files |
---|
80 | %defattr(-,root,root) |
---|
81 | /* |
---|
Note: See
TracBrowser
for help on using the repository browser.